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1. Download Federal Electoral Districts and add to map document 
Federal Electoral Districts (FEDs) are the geographic areas for which one Member of Parliament is 

elected. It is downloaded as a shapefile which can then be viewed in QGIS. 

1) In an internet browser, go to geogratis.gc.ca. 

2) After you’ve selected English, click GeoGratis Catalogue 

3) Type federal electoral districts in the search box and click Search 

4) Click on GeoBase – Federal Electoral Districts and then on Federal Electoral Districts – Canada 

2013 

5) Scroll down and click on the SHP button underneath Download English file in SHAPE through 

HTTP 

6) Wait a moment for it to download. Spend that time trying to make sense of the gobbledygook 

name. Or not. We don’t care. 

 
7) Once it has downloaded, copy the ZIP folder into the project folder for today’s class. We suggest 

a hierarchy like this, but we’re particular about this stuff: 

 
8) Unzip the file. If you don’t, you may get an error when you try to import it into QGIS. 

9) Once unzipped, your folder should look something like this: 

 
This is as good a time as any to note that shapefiles look like multiple different files when you 

view them in Windows Explorer. If you ever copy and paste them somewhere, you need to have 

all the parts (e.g.: all the files that have the same name before the file extension – there may be 

up to 8 of them). 

10) You’re done the download! Yay! Give yourself a pat on the back! 

11) Open QGIS. Once QGIS opens, add the dataset by clicking on Layer > Add Layer > Add Vector 

Layer… Browse to the project’s folder and find the shapefile. Click on the .shp and click Ok to 

add the shapefile to QGIS. 

a. You could also have the project folder open in Windows Explorer and just drag and drop 

the file in. Either way works! 

http://geogratis.gc.ca/
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12) Click View >Panels and make sure Browser and Layers are both selected. 

13) In the Layers panel, right click on the FED layer and click Properties. In the General tab you’ll 

notice that the shapefile has a coordinate system of NAD83 / Statistics Canada Lambert. Click 

Ok to close the dialog box.  

 
14) Because the next step involves displaying latitude and longitude points in a specific projection 

(WGS 84), we need to save the FEDs in that projection as well. Right click and select Save As… 

15) In the Save vector layer as… dialog box:  

a. Make sure the format is ESRI Shapefile 

b. Browse to your project folder and save as FEDs_WGS84  

c. Click the Selected CRS button  located after the CRS dropdown menu.  

d. In Filter textbox, type WGS. Select WGS84 / EPSG:4326 from the results below. Click OK. 
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e. Make sure Add saved file to map is clicked. Click OK. 

16) Right-click on FED_CA_2_1_en in the Layers panel and select Remove. 

 

2. Add and Display Federal Contaminated Sites 
The Federal Contaminated Sites was downloaded as an Excel file and converted to CSV. Included in the 

data of this CSV file are rows for latitude and longitude, which we’ll use to display in QGIS. If you don’t 

have this file, go to http://madgic.library.carleton.ca/deposit/GIS/temp/2016/ and download it. 

1) Go to View > Toolbars and make sure that the Manage Layers toolbar is selected. 

2) Click the Add Delimited Text Layer button.   

3) A dialogue box will pop up. Fill it in accordingly: 

a. Browse to the ContaminatedSitesWorkbookforQGIS.csv file in your project folder 

b. Make sure CSV is selected as the file format 

c. Geometry definition is Point coordinates with X field as Longitude and Y field as Latitude 

i. If you get an error message about six missing records, close the dialog box and 

keep going.  

 

 

http://madgic.library.carleton.ca/deposit/GIS/temp/2016/
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4) Click OK. In the following Coordinate Reference System Selector dialog box, type “wgs 84” in the 

filter text box and select WGS 84 / EPSG:4326 from under Geographic Coordinate Systems.  

 

5) Click OK. This will display the longitude and latitude of each contaminated sites record for 

Canada. Hooray! 

6) We need to save the file as a shapefile in order to keep the display and not have to do it each 

time. In the Layers panel, right click on ContaminatedSitesWorkbookforQGIS > Save As…  

a. Format: ESRI Shapefile 

b. Browse to your AmazingMap > Shapefile folder and name it contaminated_sites.shp. 

c. Ensure CRS is EPSG:4326, WGS 

84 

d. Make sure Add saved file to map 

is selected  

e. Click OK 

7) You should now have 3 layers in QGIS. 

Right click on 

ContaminatedSitesWorkbookforQGIS 

and select Remove. 

8) The 2 layers now in the QGIS Layer panel 

should be contaminated_sites.shp, which 

is on top of the federal electoral district 

boundary.  
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3. Querying and Extracting 
When confronted with a large dataset you may want to use the querying capabilities of QGIS to extract 

one or more subsets. 

1) Right click on the contaminated_sites.shp and select Open Attribute Table. 

2) You will note that there are 771 features in the dataset. 

In order to query the data, click on the Select features using an expression button  on the 

attribute table toolbar.  

3) The Select by expression dialog box will appear. It allows you to create a query statement that 

will select features that conform to the parameters you set. In this example, we will search for 

only high priority for Action sites, which have a value of 1 in the ClassType field. 

a. Start off by making the Select by expression dialog box wider. It will make sense shortly. 

b. In the middle window, click the + sign beside Fields and Values to see all the fields in 

the attribute table. 

c. Double-click ClassType. It will show up in the Expression window. 

d. Above the Expression window, click the = button so it shows up after ClassType. 
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e. On the right, beside Load values click the all unique button. The result will be NULL and 

1. Double-click 1. 

f. Your Select by expression dialog box should now look like this: 

 
g. Click the Select button. Note that many contaminated sites points are now yellow. 

h. Click Close. 

i. Close the attribute table as well. 

4) The selected features are only temporary and we want to deal ONLY with the high priority sites, 

so we’ll export the currently-selected sites to a new shapefile. 

a. Right-click on contaminated_sites and select Save As… from the menu 

b. Before you do anything else, select the Save only selected features option  

 
c. Browse to where you would like to save your file. We recommend naming it something 

helpful, such as contaminated_priority.shp. Ensure that you save as type ESRI Shapefile   
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d. Click Save and then OK in the “Save vector layer as” dialog box. 

e. Wait a moment for it to export and add the file. 

f. Click on the checkbox beside contaminated_sites to turn it off and view only your new 

layer. 

5. Extracting British Columbia FEDs 
Selecting features from a shapefile allows users to identify or more easily locate a subset of features on 

your map. You’ll most likely work with selected features when you are querying, exploring, analyzing, or 

editing data. Applying a selection is also a way of specifying the features for which you want to calculate 

statistics, view attributes, move, export as a new layer, and so on. 

1) Right-click on FEDs_WGS and select Open Attribute Table 

2) Click on the Select features using an express button  on the attribute table toolbar.  

3) Like with the querying we did a moment ago, we will construct an expression to select only FEDs 

in British Columbia. In this case, the expression is "PROVCODE" LIKE ‘BC’. (NOTE: You’ll 

recognize this statement from your MySQL work) 

 
4) Click Select. You should now have 43 of 347 selected in the attribute table. 

5) Close the Select by expression window.  

6) Click the Toggle editing mode button . Close the attribute table. 

7) We’re now going to export ONLY the selected British Columbia FEDs. To do this, right click 

FEDs_WGS84 and select Save As… 

8) In the dialog box, make sure that it says Save only selected features. 

9) Browse to your project folder and save the file. We saved it as FEDs_BC.shp. 

10) Unclick FEDs_WGS84 and your map should have just BC and all the priority contaminated sites. 
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6. Calculate how many points are found in a polygon 
Sometimes it is helpful to know how many instances of something (like priority contaminated sites) 

occur within a particular area (like FEDs in British Columbia).  

1) Right click on the FEDs_BC and select Zoom to Layer to view it at its extents. It should look 

something like this with the contaminated_priority layer turned on as well. 

  
2) We first need to delete all extraneous fields in contaminated_sites because QGIS is finicky about 

it (a.k.a. it refuses to join layers with null values). To do that, right click and select Open 

Attribute table. 

a. In the attribute table, click the Toggle editing mode button  

b. Then click the Delete column button.  

c. In the Delete Attributes dialog box, scroll down then click and select everything from 

Involvem_1 to MediumName. 

d. Click OK. 

e. Click the Toggle editing mode button again and save the changes when prompted. 

f. Close the attribute table. 

3) We need to do the same thing for FEDs_BC. 

Repeat the steps above but select all the 

fields after PROVCODE, as shown: 
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4) In order to find out how many high priority contaminated sites are in each BC FED, we will 

perform a spatial join. In the menu bar, click Vector > Data Mangement Tools > Join attributes 

by location. 

5) Fill out the Join attributes by location dialog box as 

seen here: 

a. Target vector layer: FEDs_BC 

b. Join vector layer: contaminated_priority 

c. Summarize by Sum (this will provide a total 

number of contaminated sit 

d. Browse to the location you wish to save your 

resulting shapefile, and name it something 

helpful like FEDs_BC_PrioritySites. 

e. Keep all records. 

 

6) Click OK, and then close the Join attributes by location 

dialog box 

7) FED_PrioritySites will be added to your map. Right-

click and Open Attribute Table. 

8) Note the COUNT field. This gives a total of priority contaminated sites within each electoral 

district. 

9) Double-click on the COUNT field name to sort it numerically (ascending). Double-click it again to 

sort descending. 

10) To symbolize the FEDs_BC_PrioritySites shapefile based on the COUNT field, close the table and 

in the table of contents right-click FEDs_BC_PrioritySites and select Properties. 

11) Click the Style tab in the Layer Properties dialog box. 

12) Click Graduated in the drop-down box at the top 

13) Fill it in as seen below (details on next page): 

      (NOTE: depending 

on your version of QGIS, your dialog box may look slightly different.) 
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a. Column should be COUNT 

b. Under the Classes tab, Mode should be Natural Breaks (Jenks) with 5 classes 

i. You can play around with this if you’d like 

c. Pick your favourite colour ramp. As you are showing density, go with something that’s 

the same hue but with varying intensity. If you go with a many-coloured ramp your map 

becomes meaningless, like so: 

                                

14) Your on-screen map should now look something like this, with the darker hues showing us which 

FEDs have the most contaminated sites. 

  

13) Let’s not spend too much time here as sections 7 & 8 focus on creating our map layout and making 

sure that our map looks just right! 
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7. Downloading and Joining Census Data 
We now want to look at the census data for the FEDs in British Columbia to perhaps find a pattern. The 

Census includes information about population & language while the National Household Survey (NHS) 

includes data about income, immigration, workplace, and more.   

1) Go to www.Statcan.gc.ca  

2) For Census Profile, go to Browse by key resource > Census Profile 

3) For NHS, scroll to the bottom right, under the section Other Links, click on 2011 National 

Household Survey (NHS) 

4) At the right of the screen, you’ll notice a section called Download – Complete geographic level 

a. Select the IVT or XML (2011) 

b. This will download the data in beyond 20/20 format, which can viewed in the free 

beyond 20/20 browser (windows-based computers). 

i. Download Beyond 20/20 browser - 

http://www2.beyond2020.com/SC/ProBrowser.exe 

ii. How to use Beyond 20/20 - https://library.carleton.ca/help/beyond-2020-how-

use-beyond-2020 

5) Since we don’t have beyond 20/20 here, we’ve exported a .csv file from Beyond 20/20 for you to 

use. Open the .csv file in Excel. You’ll need to perform the following clean-up on the data to 

extract the FED codes, which we’ll use to join to the boundary file. 

a. Find & Replace “ (“ with a comma. 

b. Find & Replace “)   “ with a comma. 

c. Run the Text to Column and separate based on the comma. This will separate out the 

FED codes, which we’ll use to join to the boundary file. 

d. Remove the unwanted rows and keep only the 5 digit numerical codes. 

6) In QGIS, go to Layer > Add Layer > Add Delimited Text Layer… 

7) Fill in the following information then click OK 

a. File format: CSV 

b. Geometry definition: No geometry (attribute only table) 

 

http://www.statcan.gc.ca/
http://www2.beyond2020.com/SC/ProBrowser.exe
https://library.carleton.ca/help/beyond-2020-how-use-beyond-2020
https://library.carleton.ca/help/beyond-2020-how-use-beyond-2020
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8) Right click on the FEDs_BC_PrioritySites polygon file and select Properties. 

9) From the Properties window, select Joins and click on the green + button.  

10) Ensure that join of the table data to the polygon is based on a common field. 

 

11) Click OK. 

12) Right click on FEDs_BC_PrioritySites > Save as…Ensure that you set the CRS of the file as WGS84 

and save the file as FEDs_BC_PrioritySitesIncome. The join is now complete.  

13) Open the attribute table of your newly saved file to see the NHS data.  

14) Remove the FEDs_BC_PrioritySites from the table of contents – just so we don’t get confused! 

8. Symbology and labels 
Let’s take a look at how we can use symbology and labels to provide us with layers of information from 

the same shapefile. 

1) Open the attribute table for FEDs_BC_PrioritySitesIncome to view the table with the NHS data 

joined to it. Note that the column names for the table are not helpfully named. We can change 

that! 

2) Right click on FEDs_BC_PrioritySitesIncome and select Properties…. 

3) Click on the Fields tab 

4) On the left you will see a list of all the fields. Scroll to the bottom to see IncomeData, 

IncomeData1, IncomeData2. On the right of the window, change the Alias to something helpful 

for each field. Click Ok when done. 
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5) Change the symbology of FEDs_BC_PrioritySitesIncome to a colour ramp based on Average 

Income. (Refer back to page 6 if you need a quick reminder on how to do that.) Click Apply. 

6) Now let’s label each FED with the number of high priority contaminated sites! Whee! 

7) In Properties, select the Labels tab. 

8) Check the Label this layer with box and set the label field to Count  

9) Choose your label font. In the example it’s Arial, size 12, bold, white. 

10) Click OK. 
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11) Your map should now look something like this: 

 

9. Creating a Map Layout 
To create a map layout in QGIS, you need to make a Composer. This will enable you to place and arrange 

map elements such scale bar, a legend, and a map title.  

1) Start off by right-clicking the layer you want to create a layout for, and select Zoom to layer. 

2) In the menu, select Project > New Print Composer.  

3) In the Composer title dialog box, give your new composition a name. Click OK. 

4) A new Composer window will appear. To add your map of BC, click Layout > Add Map, then 

draw a box that is just inside the perimeter of the page. 



Prepared by Joël Rivard and Rebecca Bartlett, Carleton University Library, Nov. 2016 15 

 
5) Under Extents, click the Set to map canvas extent button to centre the layer. 

6) If BC is either too large or too small for your liking, fiddle with the Scale under Item properties 

on the right.  

a. A larger number will make BC smaller and a smaller number will make BC larger. 

7) The QGIS composer is remarkably finicky. Maneuver (including deleting and re-adding) the map 

around until you’re reasonably satisfied. 

Adding Other Map Elements 

Adding a Legend 

1. In the menu, select Layout > Add Legend.  

2. Draw a box where you would like your legend to appear. 

3. By default, all the layers on the map will appear as legend items in the legend.  

4. To remove a legend item, you need to uncheck the Auto update checkbox and then 

manually remove the layers you don’t want in your legend using the red minus 

button.  

5. To change the name of a legend item as it shows up in the legend, click the 

legend item and then the Edit button to change its title in the legend.  

6. If you would like to change the title of your legend (or prefer that it doesn’t have a title at all), 

change it in the Title textbox under Main properties. 

7. There are a lot of options in the Legend panel, from font selections to spacing to background 

colour. 

8. You can click and drag the legend into place on your map. 

Adding a North Arrow 

1. In the menu, select Layout > Add Image. 
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2. Draw a box where you would like to see your north arrow. 

3. In the Item properties panel on the right, click on the Search Directories submenu, and under 

Image search paths find the one ending in /arrows. 

4. Select an arrow that meets your needs. You could always design your own if you feel creative, or 

just go for a Star Trek vibe (never a bad idea): 

 

Adding a Scale Bar 

1. In the menu, select Layout > Add Scalebar. 

2. Draw a box where you would like to see the scale bar. 

3. In the Item properties tab, you can select one of six styles under the Style dropdown. 

4. Choose the units for the scale bar under Units. 

5. Adjust the segments in the Segments area. 

a. E.g.: left 0 and right 4 on a Line Ticks Up style will look something like this: 

 
6. Click and drag the scale bar into place on your map.  

Adding a Title to a Map 

1. In the menu, select Layout > Add Label. 

2. Draw a box where you’d like your title to 

be (you can move it later). 

3. Type your title into the Main properties 

text box. 

4. Adjust the font as you see fit and move it 

around until you resign yourself to the 

lack of design elements included in QGIS. 

10. Geocoding 
We’ve looked at a lot of files today, but most 

were already in a mapping format. The following 

section will describes the steps to geocode a file that only street addresses. We’ll take a look at 

inspection violation file, from which we’ve extracted Tim Hortons stores.  We’ll explore two methods of 

geocoding as well as the format and cleaning-up process that’s required. 

Method 1 – Using Google Maps / OpenStreetMap 

This method uses the Google Maps API or OpenStreetMap API to geocode the location of the points. 

This is optimal if you have a thousand points or less to geocode. 

This is not a very pretty map. You can make a nicer one. 
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Cleaning-up the data: 

1) In Excel, open the Tim Hortons file - TimHortonsViolationsForMapping.csv. 

2) Clean-up the file to have the address elements in separate columns. 

a. Move the content of row C to row G 

b. Highlight Row B, from Find and Replace, select Replace. Do the following Find & 

Replace 

i. Replace “S  “ (S with two spaces) with a S comma 

ii. Replace “ , “(space comma space) with a comma 

iii. Replace “, “ (comma space) with a comma 

iv. Replace “  “ (two spaces) with one space 

c. Highlight Row B, click on Text to Columns 

i. Select Delimited, space as the delimiter. 

d. Scroll through your data to ensure that all data was changed properly. Line 87 has to be 

changed. 

e. Change the column headers to Store, Address, Province, Country 

f. Save as a new Excel file - TimHortonsViolationsForMappingCLEAN.csv 

Geocoding in QGIS 

1) In QGIS, go to Plug-ins > Manage and Install Plug-ins and ensure that MMQGIS is selected. 

2) In the menu, click on MMQGIS > Geocode > Geocode CSV with Google / Open StreetMap 

 

 
a. Ensure that the following is selected for the geocoding. You’ll have to match the 

proper fields to the geocoding field. (ie. Address Field needs to correspond to the 

filed that has an address – 123 colonel by drive). 
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b. Click Ok. Geocoding will run. 

Method 2 – Using Street Layer 

This method uses an existing street layer file to geocode your points. In this case, we’ve downloaded the 

street file from Ottawa Open data. 

Cleaning-up the data: 

1) In Excel, open the Tim Hortons file - TimHortonsViolationsForMappingCLEAN.csv. 

2) Clean-up the file to have the address elements in separate columns. 

i. Use Find&Replace and TextToColumns to separate address number and 

streetname into separate columns. 

ii. Use the Find&Replace function to change the street type suffix to the 

acronym. (ie.Road to RD, Street or ST, etc.) 

iii. Save the file as TimHortonsViolationsForMapping-CLEAN-STREET.csv 

Geocoding in QGIS 

1) In QGIS, add the Road_Segments.shp to QGIS (this was downloaded from Ottawa 

OpenData) 

2) Go to MMQGIS > Geocode > Geocode from Street Layer 
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3) Fill in the following information in the dialog box. Ensure that you select ROAD_NAME_ 

and not ROAD_NAME 

 

4) Click Ok to run the geocoding. 

5) Once complete, you’ll notice that it didn’t geocode all of the files. Take a look at the 

notfound.csv file to see which records weren’t geocoded. Can you tell us why? 

 


